Welcome to PressWork!

Want to ask a question or join the discussion? Great! Join now.

In this Discussion

Overriding Fonts Toolbox selection with custom CSS?
  • Summary/tl;dr version: Currently, the fonts toolbox only allows the selection of one font for the post titles displayed on the blog. I would like to set two fonts for the post titles: Quattrocento for Latin text, and Simsun for East Asian text.

    Normally, a css font-family attribute would work. However, the custom CSS I added is being ignored in favor of the font selected in the Fonts Toolbox. How should I work around it?

    Long version:

    Hello PressWork support; currently, I am in the process of making a personal blog where entries will be posted both in Chinese and English. Right now, while I would prefer to use a western font for English posts, the post titles in Chinese are rendered in a messed-up fashion, due to an unfixed bug occurring in most major browsers including at least IE and Firefox (Instead of using a single fallback font to render East Asian characters, the page renders with a conglomeration of MS PGothic and Simsun for Chinese characters on the same line, making it very difficult to read).

    While I understand how to add fonts like Simsun to the list of Google Fonts for the fonts toolbox, the toolbox only allows one font to be selected for the headers/post bodies, respectively. As you can imagine, setting the font to Simsun causes the English posts to look visually unappealing.

    I've heard that a fix for this rendering issue exists, by specifying a East-Asian font in the page CSS. However, I've inserted the following snippet into custom.css and placed it in the correct folder, yet no change occurs.
    article .posttitle {
    font-family: helvetica, arial, simsun, sans-serif;
    }


    The blog continues to render English posts with a Quattrocento font, showing that the font-family attribute specified in the CSS file is being overridden with the font choice selected in the font toolbox.

    I've verified that the custom CSS file is indeed being loaded, because if I specify an attribute like font-size: 15.0em;, then the font size will change to the gargantuan number I put down. However, the font-family attribute appears to be entirely ignored. Is there some way to work around this?
  • Just curious, have you tried using...


    !important;