Welcome to PressWork!

Want to ask a question or join the discussion? Great! Join now.

In this Discussion

header image won't appear
  • Hi have just installed Presswork theme on my new domain. First thing I've tried to do is upload a header image. Used a 930x160 pixel jpeg but it won't appear on the page. What have I done wrong? Or is there a basic fault in the theme?

    thanks
  • cestbibicestbibi
    This answer was Accepted.
    How did you upload your image ?
    Did you set the path to your image in the Toolbox ?
    Can you provide a link to your site ?
    image PressWork Support Moderator
  • Hi Cestbibi
    a. I uploaded through the Header link under Appearance.
    b. There was no instruction to set the path in the toolbox (is that the panelon the bottom left of the homepage?)
    c. www.wizewords.com.au

    Also I made some changes to the menus, and they haven't taken affect either.
  • Hi
    I got the Logo to appear, but trying get things to appear where I want them to is impossible. Plus things just seem to disappear.
    Love the design but think I'm going to have to bail, due to the functionality gap with this novice user. cheers
  • Thanks for trying PressWork
    image PressWork Support Moderator
  • Another novice who can't find the answer in the forums (and I have searched). I am trying to change the logo to my own. Do I need briefcase for this, or can I edit somewhere. I know a little CSS/HTML, so I am not totally in the dark there.
  • No need of Briefcase, you just have to upload your image/logo to your server (you can use the Media Upload of your Wordpress Dashboard for example, see this if you don't know how todo it
    ).
    Then copy the link to your image/logo and paste it on the Toolbox on Layout --> Logo Image URL and you are done.
    image PressWork Support Moderator
  • Thanks! This is what I have been trying to do, but it just defaults back to the original. The original is https://visualepidemic.info/wp-content/themes/presswork/admin/images/logo_front.png and my edited version is https://visualepidemic.info/wp-content/themes/presswork/admin/images/academic.png. Perhaps the edited one is too large.
  • Actually, it seems like my toolbox -> layout is not working. I could change colors of my links in the other toolbox ->color, but if I want to add anything in the layout part, the changes do not stay. I am not sure why that is.
  • Are you on Wordpress 3.3 ?
    image PressWork Support Moderator
  • cestbibi said:

    Are you on Wordpress 3.3 ?


    Her source code says that she's on 3.3.
  • Yes, I upgraded before installing the theme
  • I also have tried running my page through the W3 page check and have disabled my plugins - just in case. Neither worked.
  • Toolbox is broken with WP 3.3 that's why you get all these problems. We are waiting for PW 1.0.4 that'll fix those problems, but i'm afraid no release date yet.
    image PressWork Support Moderator
  • Ah, thanks Cestbibi. I will look for the new version.
  • Half-arsed themes like this should come with a health warning - to avoid wasting everyone's time
  • If you are adding a header image, you need to also add the element under the Layout options.
    image Senior Developer & Co-Founder of PressWork
  • I am having the same issue. Worth noting, that when the header items are updated using the toolbox, MySQL is writing the query value as [object Object]. I think values are not being parsed correctly into the DB, so there is nothing to retrieve.

    Besides that, I really enjoy the theme - complex, but flexible!
  • @Bradley Are you referring to the header image or the header logo?
    image Senior Developer & Co-Founder of PressWork
  • I'm encountering the same problem. With Wordpress 3.3.1, layout additions like adding a header image using the Toolbox don't save, they reset when I reload the page. I've created a child theme to try and address this problem. Any tips for how to add a header image using a child theme and custom actions/css? I'm pretty competent modifying wordpress themes but Presswork's use of actions.php to lay out everything is hard for me to understand.
  • I am also facing the same problem. I tried header image and header logo separately but no help.I have wordpress 3.3.1 , what is the toolbox your are talking about?
    Post edited by agarwlGaurav at 2012-02-10 10:17:33
  • Please update manually to PW 1.0.4
    https://github.com/digibomb/PressWork
    image PressWork Support Moderator